Tags

, , , , , , , ,

At the time of unoconv installation if you are getting the below error message
error: Failed dependencies:
openoffice.org-pyuno >= 2.0 is needed by unoconv-0.5-1.el6.rf.noarch

Then follow the below steps:

Note:
– Before following the below steps if you already installed the libreoffice packages then remove them one-by-one using yum remove [PACKAGE NAME] command.
– libreoffice needed for centos6.4 & openoffice needed for centos6.5.

Steps to install unoconv and openoffice on centos6.5
1: Login to your server through SSH using root credential

2: Create a file named(can be any name with .repo) Archives.repo

3: Add the following snippet
####################################################
[c6-archives]
name=CentOS-6 – Archives
baseurl=http://vault.centos.org/6.2/updates/$basearch/
gpgcheck=0
enabled=1
####################################################

and save this file to /etc/yum.repos.d/ directory

4: Execute the command yum clean all.

5: execute the below command
yum install unoconv openoffice.org-headless openoffice.org-writer openoffice.org-calc openoffice.org-impress

6: Hope above helps 🙂

Advertisements